Announcement

Collapse
No announcement yet.

Electrolyte

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Electrolyte

    Hiya folks.

    I have 2ltrs of battery acid (36% sulphuric acid) from a motorfactors, mixed with 5ltrs of deionsid water as my electrolyte.

    Now I have my power supply connected up and everythings okay, if i touch the ground plate and the anodised part together lots of sparks etc....

    But when they are submerged in the electrolyte the power supply shows no current flowing

    I have the voltage set to 10V and nothing, even upto the max of 16v (POwer supply is CV 0-16v @40A max)

    Anyone know why I am getting no current passed? The contacts are all good, i dont understand it

    Cheers

  • #2
    If all of the connections were good, current would flow. Its obvious that they aren't.

    You will need to provide more information.

    Comment


    • #3
      Thanks.

      I believe I have found my error, I used some new sheet aluminium (believed to be 2018 alloy).

      I took the plastic cover off and used it right off (as i dont have any anodize stripper just yet ). I think this is my problem on those peices I tried, I think they had oxidised, and as such obviously wouldent allow current to flow!

      I tried another larger sheet I had, and it flows nicely (1amp).......first attempt! and i have made the first mistake! .

      Must get myself some oxide/anoidse stripper and propperly prep the part!

      I *hope* that was my error anyway!

      Comment

      Working...
      X