Announcement

Collapse
No announcement yet.

Issue/question with CopyCad kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue/question with CopyCad kit

    I'm new to plating. I've been doing nickel plating for a couple weeks with pretty good success.
    I just got the CopyCad chemicals and zinc anode from Caswell and I've run into a problem. I can't get my power supply (CV, CC adjustable. 150W) to regulate current. I put a small nut into the solution, I can turn up the current and voltage limits to their max and I only get about 30mA. I've tried different wires, different parts, moving the anodes, going to one anode, etc.
    I switched back to my nickel solution and with the same part I can regulate current anywhere from a few mA to a couple amps.
    It seems like something with the plating solution is causing the issue. I bought the 1.5 gal set and only mixed a gallon using 2/3 or part A and part B. I also used RO water.
    Any ideas on what's going on? I'm going to try a different power supply, but since this one works with nickel, I'm not expecting that to be the problem.

  • #2
    You can NOT partially mix our Copy/Cad Zinc. The part B has several ingredients, scooping some out will not work.
    --
    Jason Vanderbroek
    315 946 1213 x116
    www.caswellplating.com

    Comment


    • #3
      Thanks Jason. I mixed up the remainder of part B and A and added another 2 quarts of water to make a total of 1 1/2 gallons. It's still acting the same. I even tried another power supply.
      Any other ideas?

      Comment


      • #4
        Turned out to be the power supplies I was trying. They apparently can't control currents as low as I needed, and the meters on them are notoriously wrong. I tried a third supply and it's working find.

        Comment

        Working...
        X