Announcement

Collapse
No announcement yet.

copy chrome and aluminum problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • AresP
    replied
    Buff or polish the aluminum surface to a bright shine. Wash with a mild detergent and do not dry. Apply Aluminum Cleaner by dipping or brushing it onto the work-piece. Note this is not an electroplating step.

    Rinse with clean water and without delay dip or brush on the Zincate Solution, you should get a light gray coating on the aluminum.

    If the coating is not even or has places without color. Cleaning and re-zincating is required. This is not an electroplating step.

    To activate/clean the aluminium prior to zincating, some people use diluted lye

    Maybe the problem is improperly cleaning/activating your aluminium surface before the zincate step.

    Leave a comment:


  • jtagger19
    started a topic copy chrome and aluminum problems

    copy chrome and aluminum problems

    I'm trying to plate aluminum with a copy chrome kit but I'm having problems
    it's coming out of the tank looking like sand paper once I dry it it starts to delaminate
    I have tried all kinds of different amp settings and it's still happening
    solution is not contaminated because everything else comes out great
    (coopper pipes and metal)
    the last thing I can think of is the zincate cuz is the only thing aluminum use that others don't .
    is there any special way to zincate it ?
    I just dip the part and after 2-3 minutes the part stops bubbling and I take it out and plate it.
    any ideas
Working...
X