Announcement

Collapse
No announcement yet.

Help with PLug n plate kit

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • dadkar2
    replied
    Is the Plug n' Plate kit a chrome kit or copy chrome? I'm not sure you'll see much contrast on steel if you try the chrome component alone?! You'll have to lay down the nickel first, I imagine, for much to be visible.

    Compared to steel, nickel will have a slightly yellowish cast. Then when you apply the chrome over the nickel, it will take on a slightly bluish tint.

    Of course if it is copy chrome (or if you are plating with the nickel component of a chorme kit), then you should be able to see that pretty clearly on copper as Caswell said.

    Kind regards,
    Ken

    Leave a comment:


  • mcaswell
    replied
    Sometimes it is very difficult to see a difference on a white metal.

    Try plating a piece of copper as a control. It should turn out a little smutty and grey and will need polishing. If it works on the copper, it's working on the steel.

    Leave a comment:


  • allcarfan
    started a topic Help with PLug n plate kit

    Help with PLug n plate kit

    I just received my chrome plug n plate kit.

    I had to use it as soon as I got it...of course. So, i got an old brake dust shield in the garage. I polished a little spot on it with a 320 grit die grinder. Then i cleaned it. Then I wiped it with acetone....wiped it with a dry cloth.

    I hooked in the wand, grounded the dust plate. I put a little of the solution in the cap of the bottle. wrapped the wand with some of the provided gauze....dipped it in the solution. I started rubbing the small, prepped spot....slowly at first....and I could hear some fizzing....but saw nothing. I decided to move the wand a little faster and press down...still....nothing. I let it dry...redipped the wand and started again....still....nothing. I decided that maybe if I buffed it, it would make a difference. I got my dremel and some never dull....made it nice and smooth. I polished another small area right next to it with my 320grit die grinder and didnt do anything else to it...I compared the two...they look exactly the same....

    Am I doing something wrong?
Working...
X