Announcement

Collapse
No announcement yet.

Copy Chrome tank contaminated...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • hefrod
    replied
    Re: Copy Chrome tank contaminated...

    I got a metal piece very large and plated it. It had some very bright chrome on it. Now the chrome did peel off a bit but it was a very nice brilliant chrome color. It appears the dummy worked well.

    I am going to plate a nice copper finished piece tomorrow morning so I will see how it does. Thanks alot!

    Leave a comment:


  • mcaswell
    replied
    Re: Copy Chrome tank contaminated...

    Since you're running a 30 Gal tank, your dummy should be much bigger than the size in the tech document. As big as you can make it.

    Leave a comment:


  • hefrod
    replied
    Re: Copy Chrome tank contaminated...

    Beautiful!!
    Ta\hank you very much

    Leave a comment:


  • mcaswell
    replied
    Re: Copy Chrome tank contaminated...

    Just added to Support Section:

    http://support.caswellplating.com/in...nloaditemid=14

    Leave a comment:


  • hefrod
    started a topic Copy Chrome tank contaminated...

    Copy Chrome tank contaminated...

    Hey folks,
    I continue to get a dark deposit on my product when doing the Copy Chrome step, it's a very dark grey.

    In the manual it says I probably have Zinc, Lead, or Copper in the solution.
    I know it can't be Lead for sure... But I was using a copper wire connected to the Cathode could this be it? Also I could possible have copper in it from my Flash Copper tank...

    Are the 30 gallons of Copy Chrome now unusable or is there a fix for this tank solution? It says "Plate out onto a dummy corrugated cathode" No Idea what that means

    Thanks
Working...
X