Announcement

Collapse
No announcement yet.

Wheel Chroming Kir-Need Help!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • enedan
    started a topic Wheel Chroming Kir-Need Help!!!

    Wheel Chroming Kir-Need Help!!!

    Hello
    First i want to apologise for my english.I am from Romania(Europe)
    I have buyed a wheel chroming kit from Casell INC.
    I don't know what is the problem,i have the kit for 3 mounths.I didn't made not even a wheel until now!
    I sundblast the wheel,polished,water break is OK.Degrease it,and zincate.After zincate i plate with Flash copper.I have agitation in the tank!I don't know what else can i do.Here is a picture with one wheel after flash copper

    http://i305.photobucket.com/albums/n...n/SP_A0374.jpg

    Please,i need some help.

    Any sugestions??

    Thanks

    Ene Dan

  • KCV6
    replied
    Re: Wheel Chroming Kir-Need Help!!!

    That is definately way too much voltage and therefore way too much current. Flash copper runs around 2Vdc in ideal conditions. Unless the wheel kit flash copper is different to the normal flash copper. Also Flash copper runs at a higher temp.

    Cheers

    Mark

    Leave a comment:


  • enedan
    replied
    Re: Wheel Chroming Kit-Need Help!!!

    I am soory,i am new on this forum.

    The metal i want to plate is aluminium.
    Surface are is approx 1200 sq inches.
    I am using Whell Chroming Kit.
    Amperage used is(75 amps-flash copper)
    Voltage-aaprox 5 volts.
    Temperature of plating bath-room temperature approx 77,0 Fahrenheit.
    The kit contained a power supply,but this power supply was small,and i bought a biger one.
    I have sundblast the wheel,polished,degrease it,water break test is OK,Zincate and then plating with flash copper(for approx 1 hour).

    Take a look at the picture,and if you can help me please post here.

    Thanks!

    Leave a comment:


  • amerdunbar
    replied
    Re: Wheel Chroming Kir-Need Help!!!

    From the looks of your part, your amps are too high, or the anodes are too close to the wheel. It also looks like some places possibly weren't zincated completely.

    Waterbreak should be done after degreasing - before you plate.

    Leave a comment:


  • lcaswell
    replied
    Re: Wheel Chroming Kir-Need Help!!!

    Please read this post and then post all the parameters - then we can help.

    Leave a comment:

Working...
X